WordPress - Wetenswaardigheden

Visual Composer & Gutenberg

WordPress 5.x is alweer een aantal weken uit en daarmee is de Gutenberg-editor een feit geworden. We hebben al geruime tijd als beta-tester WordPress 5.0 mogen testen alvorens deze daadwerkelijk aan het “grote publiek” vrijgegeven werd.

WPBakery (voorheen Visual Composer), als één van de marktleiders op het gebied van de Page-Builders voor WordPress had al in mei van het afgelopen jaar aangegeven volledig compatibel te zijn met Gutenberg. WordPress 5.0 is eind November-2018 officieel gelanceerd (7 maanden na de uitspraak van WPBakery, dat de VC compatibel zou zijn…).

Nu ruim twee maanden na de lancering van WP5.0 en een aantal updates verder, eens kijken “hoe compatibel” WPBakery nu eigenlijk is.

De Test

Voor deze test hebben we een volledig schone installatie van WordPress gedaan op een lokale WAmp-Server. De versie van WordPress is nu 5.02.

Alle plugins hebben we verwijderd en alleen de allerlaatste versie van WPBakery (de commercieel verkrijgbare) actief. Het thema wat we gebruiken is Twenty Nineteen; het thema speciaal gemaakt voor WordPress 5.0 en Gutenberg.

Schone WP Installatie

Pagina vanuit WPBakery naar Gutenberg

Nu hebben we eerst een nieuwe pagina aangemaakt en zijn die pagina gestart met het bouwen vanuit WPBakery. We hebben een rij toegevoegd en die onderverdeeld in 4 kolommen. In die kolommen plaatsen we van links naar rechts een tekstblok, een afbeelding, dan weer een tekstblok en dan weer een afbeelding:

Pagina gestart vanuit Visual Composer

Pagina gestart vanuit VC

Vervolgens slaan we die pagina op en gaan die dan bewerken met Gutenberg. Het resultaat:

Visual Composer Pagina Bewerken met Gutenberg

Bewerken met Gutenberg

Precies wat we eigenlijk al verwacht hadden. Gutenberg neemt alleen de pagina-titel correct over en de rest wordt in het Classic Editor -blok geplaatst en toont de Visual Composer shortcodes. Hier is dus niets veranderd ten opzichte van eerdere versies van WordPress in combinatie met Visual Composer.

Voegen we nu vanuit Gutenberg aan dezelfde pagina een Gutenberg-blok toe en schakelen we dan weer terug naar WPBakery dan gaat het ook niet goed. WPBakery ziet een kolommen-blok van Gutenberg als tekst-element. De shortcodes van Gutenberg worden wel overgenomen maar wordt verder niets mee gedaan.

Pagina vanuit Gutenberg naar Visual Composer

Bij de test om een blok-element van Gutenberg toe te voegen via de Gutenberg-editor met een pagina gestart vanuit WPBakery had ons al getoond dat WPBakery ook de vertaalslag niet maakt. Dus, deze test behoeven we dan ook verder niet uit te proberen.

Gutenberg Editor in WPBakery

Nu heeft WPBakery wel een Gutenberg-Element opgenomen:

Gutenberg Editor in Visual Composer

Via het Gutenberg-Visual-Composer-Element kunnen we nu een stuk content met de Visual Composer gebouwde pagina een gedeelte opnemen wat we dan aanmaken met Gutenberg-blokken.

We hebben als voorbeeld een tweetal Gutenberg-blokken als één Visual Composer -element opgenomen op de pagina. Net als ieder Visual Composer -element kunnen we dat element eenvoudig een rand en achtergrond kleur geven, wat we dan ook gedaan hebben.

Het resultaat aan de voorkant van de website:

Gutebergblokken in Visual Composer

We hebben hier een Gutenberg paragraaf en citaat -blok opgenomen in de Visual Composer aangemaakte pagina. Daarna een rand en achtergrondkleur ingesteld. Dat gaat dus wel goed.

Vanuit dat oogpunt is Visual Composer wel compatibel met Gutenberg. De toegevoegde waarde, die zien we nog niet; maar horen die graag.

Conclusie

WordPress 5.0 (lees Gutenberg) en de laatste versie 5.6 van WPBakery / Visual Composer werken prima samen. De enige reden die wij kunnen verzinnen dat WPBakery een Gutenberg-element heeft toegevoegd, is een marketing-reden om vertrouwen te winnen/behouden bij huidige VC-gebruikers.

Wellicht zal WPBakery in de nabije toekomst een volledige compatibiliteit (of conversie-tool) inbouwen om Gutenberg-pagina’s volledig automatisch om te zetten naar VC-elementen. Andersom, op korte of middellange -termijn zien we dat niet gebeuren, daar Gutenberg een grote inhaalslag moet doen om de huidige Page-Builders te kunnen evenaren.

Een schone, nieuwe website opbouwen met WordPress 5.0 en Visual Composer is dus geen probleem. Voor bestaande websites die opgebouwd zijn met WPBakery, blijft echter het advies voor de upgrade naar WordPress 5.x om die upgrade te doen in een offline-omgeving. Deze test was een zeer schone wat betreft installatie en zeer kaal aangaande het thema en maar één plugin. Het is niet gegarandeerd (en dat zien we, bij het schrijven van dit artikel, nog steeds dagelijks) dat huidige websites, met een uitgebreid thema en meerdere actieve plugins vlekkeloos de overstap naar WordPress 5.x ondergaan.

Vragen & Info

Heb je vragen naar aanleiding van dit artikel, stuur ons dan een mail op: info@qwain.nl of geef een reactie via onderstaand reactie-formulier.

Op de hoogte blijven van alle WordPress Nieuwtjes, Tips & Tricks… volg ons dan op Facebook .

 

Overige Artikelen


Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *